Err 99 bei Canon EOS, EF-S 17-85

Eigentlich fotografiere ich nur noch mit meiner Fuji X-E1; ab und an hole ich aber meine betagte Canon 20D heraus; deren Autofocus ist immer noch schneller als bei der Fuji. Außerdem hab ich für die Canon ein Tele und ein - wenn auch schlechtes - Weitwinkel (10-22mm). Sowie ein 17-85 Standardzoom mit Stabilizer.

Heute war es wieder soweit; ich schnappte mir die Canon und wollte ein paar Fotos machen. Leider quittierte die Canon beim dritten Foto den Dienst mit dem Err99. Der Fehler trat komischerweise nur sporadisch auf. Nach ein paar Tests fand ich heraus, dass der der Fehler nur beim Standardzoom EF-S 17-85 IS auftritt. Mit dem Fehler bin ich nicht allein; das Objektiv scheint nur eine begrenzte Lebensdauer zu haben (Siehe Link am Ende des Artikels).

Das Problem tritt bei den kurzen Brennweiten auf (bei mir unter 35mm). Das Objektiv kann bei den kurzen Brennweiten nicht Abblenden, die Kamera bekommt das mit und liefert den Fehler 99 - laut Canon Fehlerbeschreibung ein Übertragungsproblem, man möge doch mit einem Lappen den Kontakten zu Leibe rücken. Das ist natürlich Quatsch, denn bei langen Brennweiten klappts ja.

So bleibt mir wohl nur der Gang zum Reparaturcenter; Bis dahin heißt es:

  • Kamera auf manuelle Steuerung, und bei kurzen Brennweiten immer schön auf Blende 4 bleiben.

Tja, die Lebensdauer der elektronisch/digitalen Fotomonster ist leider nicht das, was man aus analogen Zeiten kennt…

Link: http://www.fotocommunity.de/forum/d-slr-fortgeschritten/canon- ef-s-17-85-defekt—89031